[PATCH] [AVAST] Compromission d’un système via une vulnérabilité au sein d’Avast

[PATCH] [AVAST] Compromission d’un système via une vulnérabilité au sein d’Avast

Après la publication de multiples failles affectant les produits Kaspersky, c’est au tour de l’éditeur Avast! d’être désigné comme potentiel vecteur de compromission. Le CERT-XMCO vous publie cette semaine son bulletin d’information relative à cette vulnérabilité.

Bulletin CXA-2015-3304
Titre Compromission d’un système via une vulnérabilité au sein d’Avast
Titre officiel Avast Antivirus: X.509 Error Rendering Command Execution
Criticité Criticite Elevée
Date 08 Octobre 2015
Plateforme Windows
Programme Avast
Exploitation Distante
Dommage Accès au système
Description Une vulnérabilité a été corrigée au sein de l’antivirus Avast. Son exploitation permettait à un attaquant de compromettre un système à distance.

La faille de sécurité provenait d’une erreur dans la gestion du champ CommonName (CNAME) des certificats X509 lorsqu’une mauvaise signature était détectée. En effet, le champ CNAME apparaissait au sein d’une fenêtre pouvant décoder le langage HTML. Un attaquant était ainsi en mesure d’exécuter du code arbitraire sur la machine d’un utilisateur en incitant sa victime à visiter un site spécifiquement conçu.

Exploit Un code d’exploitation est disponible sur notre extranet
Vulnérable * Avast
Référence https://code.google.com/p/google-security-research/issues/detail?id=546
Correction Le CERT-XMCO recommande de mettre à jour Avast via les mises à jour automatiques ou via le site web www.avast.com.
Id XMCO CXA-2015-3304
Lien extranet XMCO https://cert.xmco.fr/veille/client/index.xmco?nv=CXA-2015-3304

Cert-XMCO